RE: [SI-LIST] : Unexpected result with ICX IS

About this list Date view Thread view Subject view Author view

From: Beal, Weston (weston_beal@mentorg.com)
Date: Wed Dec 20 2000 - 11:19:08 PST


Jason,

Assuming some details that you didn't provide, I was able to see this same
problem in IS 2.4. I'll forward this to our customer support group and to
the development team for more evaluation and possible correction. It might
be a bug or it might be some parameter that we both overlooked. Please
contact me directly if this issue is not solved to your satisfaction.

Regards,
Weston

-----Original Message-----
From: Stubbs, Jason [mailto:Jason.Stubbs@marconi.com]
Sent: Wednesday, December 20, 2000 9:49 AM
To: Si-List (E-mail)
Subject: [SI-LIST] : Unexpected result with ICX IS

I'm trying to route a signal from one source to three loads with a timing
constraint of a+0.1 for all source to load traces.

If the parts are placed as shown below, the synthesis (Star topology)
provides expected results:

                              |\
                             _| \
                            | | /L1
                            | |/
                            |
  |\ | |\
  | \_______________________|________| \
  | /S | | /L2
  |/ | |/
                            |
                            | |\
                            |_| \
                              | /L3
                              |/

The S-L1, S-L2 & S-L3 delays meet the timing constraints. However, if the
loads are repositioned as shown below, something unexpected happens:

                                     |\
                                  ___| \
                                 | | /L1
                                 | |/
                                 |
  |\ | |\
  | \____________________________|___| \
  | /S | | /L2
  |/ | |/
                                 |
                                 | |\
                                 |___| \
                                     | /L3
                                     |/

I would have expected to see a meander trace added to the stub of L2 to
match the delay of L1 & L3, but there isn't. This causes a timing error.

I can't move the components, so are there any other options. Please don't
say manually route the traces!

Jason Stubbs
Marconi Communications
www.marconi.com
BXR 48000 Hardware Group
Tel: 724-742-6150

**** To unsubscribe from si-list or si-list-digest: send e-mail to
majordomo@silab.eng.sun.com. In the BODY of message put: UNSUBSCRIBE
si-list or UNSUBSCRIBE si-list-digest, for more help, put HELP.
si-list archives are accessible at http://www.qsl.net/wb6tpu
****

**** To unsubscribe from si-list or si-list-digest: send e-mail to
majordomo@silab.eng.sun.com. In the BODY of message put: UNSUBSCRIBE
si-list or UNSUBSCRIBE si-list-digest, for more help, put HELP.
si-list archives are accessible at http://www.qsl.net/wb6tpu
****


About this list Date view Thread view Subject view Author view

This archive was generated by hypermail 2b29 : Tue May 08 2001 - 14:30:29 PDT