RE: [SI-LIST] : Unexpected result with ICX IS

About this list Date view Thread view Subject view Author view

From: Cusanelli, Tony (tony_cusanelli@mentorg.com)
Date: Wed Dec 20 2000 - 11:11:09 PST


Jason,

   It is unclear as to how you entered the constraint. Here are some
common issues:

1.) Pick an edge (either rising or falling) to measure the delay.

2.) Is a+.1 the max and a the min? If so, look at the values reported in
the spread sheet and just use a hard number. For example if the delay to
load1 is the longest and is reported as .9 ns, use that as the max and .8 as
the min.

3.) Check the time resolution for the nets of interest. (it is in
Edit>Rules>Rule Classes>Checking ) The default is 50 ps - change it to 20
ps for the nets you want balanced.

Regards,
Tony Cusanelli
Applications Engineer - Mentor Graphics

-----Original Message-----
From: Stubbs, Jason [mailto:Jason.Stubbs@marconi.com]
Sent: Wednesday, December 20, 2000 9:49 AM
To: Si-List (E-mail)
Subject: [SI-LIST] : Unexpected result with ICX IS

I'm trying to route a signal from one source to three loads with a timing
constraint of a+0.1 for all source to load traces.

If the parts are placed as shown below, the synthesis (Star topology)
provides expected results:

                              |\
                             _| \
                            | | /L1
                            | |/
                            |
  |\ | |\
  | \_______________________|________| \
  | /S | | /L2
  |/ | |/
                            |
                            | |\
                            |_| \
                              | /L3
                              |/

The S-L1, S-L2 & S-L3 delays meet the timing constraints. However, if the
loads are repositioned as shown below, something unexpected happens:

                                     |\
                                  ___| \
                                 | | /L1
                                 | |/
                                 |
  |\ | |\
  | \____________________________|___| \
  | /S | | /L2
  |/ | |/
                                 |
                                 | |\
                                 |___| \
                                     | /L3
                                     |/

I would have expected to see a meander trace added to the stub of L2 to
match the delay of L1 & L3, but there isn't. This causes a timing error.

I can't move the components, so are there any other options. Please don't
say manually route the traces!

Jason Stubbs
Marconi Communications
www.marconi.com
BXR 48000 Hardware Group
Tel: 724-742-6150

**** To unsubscribe from si-list or si-list-digest: send e-mail to
majordomo@silab.eng.sun.com. In the BODY of message put: UNSUBSCRIBE
si-list or UNSUBSCRIBE si-list-digest, for more help, put HELP.
si-list archives are accessible at http://www.qsl.net/wb6tpu
****

**** To unsubscribe from si-list or si-list-digest: send e-mail to
majordomo@silab.eng.sun.com. In the BODY of message put: UNSUBSCRIBE
si-list or UNSUBSCRIBE si-list-digest, for more help, put HELP.
si-list archives are accessible at http://www.qsl.net/wb6tpu
****


About this list Date view Thread view Subject view Author view

This archive was generated by hypermail 2b29 : Tue May 08 2001 - 14:30:29 PDT